1

Recently after doing a config import via drush (drush cim sync), the config files don't seem to import properly, as the files are listed after a supposed successful import. (and doing a cex sync shows configs to export, despite nothing being changed in the backend)

The only thing I have done recently is import a copy of a database from one of our live test servers, to get the content.

Is there a UUID I need to change or something?

0

Check that the UUID of the remote and local drupal sites match.

drush config-get "system.site" uuid

You can also get the id from the remote site, by looking into system.site.yml of your config folder you are trying to import.

To set your local UUID use drush

drush config-set "system.site" uuid "UUID-GOES-HERE"
  • 1
    The UUID was the same. I fixed it somehow by exporting the configs, then re-importing them. NO idea how that fixed it, but it did. – Paul Canning Jan 26 '18 at 15:28
  • Yep, ran into that too. Every config has its own uuid. When you pulled the database from your live test servers you probably got uuids that weren't in your sync directory. – jpgerdeman Feb 23 '18 at 10:43
  • May not be uuids, When code changes sometimes extra items get added to config structures, resulting in diffs that are not of significance but still show as requiring import/export. – Alfred Armstrong Jun 19 at 14:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.