0

I am using Display Suite layouts for some of my pages. I want to add in some custom classes for the regions. However, the custom classes and custom wrappers tabs are not appearing on the Manage Display screen for my view modes. I am able to add custom classes on the Display Suite Custom Classes screen, but cannot apply them to the display, as the tabs are not there.

Am I missing something? I have seen videos where they appear for other users so don't know why they are not appearing for me.

Below is a screenshot showing the missing tabs.

Missing tabs

I want to basically target the view mode as a class on the page. At the moment, it is only inserting the layout I have selected as a class, so if I am using the same layout for different view modes I can't differentiate between them if they are for the same content type.

1

Two possibilities come to mind.

1) Have you saved since you selected "One Column" as the layout? The configuration options change once you select something other than -None-

or

2) Have you checked that you have the correct Display Suite permissions? Namely, 'Administer classes' and 'Administer fields'

  • Thank you for your answer. Yes, I have saved it and I checked the permissions as well and the tabs are not showing. I think I might need to put a request in the module issue queue. – Ben Jan 25 '18 at 11:18
  • 1
    It was my mistake. I didn't realise Drupal 8 included its own native layouts in the layout dropdown and I had selected the Drupal One Column Layout not the Display Suite One Column Layout. – Ben Jan 25 '18 at 11:24
  • Well I have the same problem. I am using indeed layouts from Display Suite and I checked the permissions and they are fine, but Custom wrappers tab doesn't show up. Any other ideas? Thanks! – Óscar Gómez Alcañiz Nov 20 '18 at 12:59
  • Forget it! I deleted the display, recreated it and suddenly the option was there... I also installed in the mean time the 'Display Suite Extras' module, not sure this was the actual solution, but worth to give it a try. – Óscar Gómez Alcañiz Nov 20 '18 at 13:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.