0

I am using Drupal 7.40. I just found a redirect issue on my website.

When I enter "http://www.website.com/node/439432" in the browser, it will 301 redirect to "https://www.website.com/myalias.html" correct.

However, I enter "https://www.website.com/node/439432" in the browser, the webpage will not redirect to my URL alias page. When I check the network, I got 200 status for the node page. enter image description here

  • First thing to do is upgrade Drupal to a recent version. 7.40 is a long, long way out of date, and there may have been a bug affecting urls that has since been fixed – Clive Jan 25 '18 at 15:46
  • @Clive I understand the version is very old. But it's hard for us to upgrade it right now. – jmu Jan 25 '18 at 15:49
0

Use the Global Redirect module to achieve this: https://www.drupal.org/project/globalredirect

  • Glad it worked! – erier Jan 25 '18 at 15:57
  • I have another question about the URL. I got double slash after my domain name, for example, website.com//page.html . I would like to remove one of the slashes. Do you have any idea how to deal with this? If not, that's totally fine. – jmu Jan 25 '18 at 16:36
  • There may be something hard-coded inside your settings.php file thats causing this. Look for the $base_url variable. There should be no trailing slash. If that's not it, I'm not sure what is causing it. – erier Jan 25 '18 at 16:53
  • Thank you very much. I found it. It's because of my view setting is incorrect. – jmu Jan 26 '18 at 14:17
  • oh, ok great. Glad it got worked out. – erier Jan 26 '18 at 16:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.