0

After adding the Internationalization module for Drupal 7, I am having some trouble with a particular block not showing up when switching languages. I set the block to be translatable (and set full html to be translatable) - the block only contains an image and is displayed in the "slideshow" region of the IV Solutions Theme. The block/image shows up fine when the page is set to English, but when the language is changed, it disappears.

Thanks for any assistance you can give-

0

Translatable means you have to actually translate it to show on the second language. On the block configuration it should give an option to translate it or perhaps check the block's visibility language settings.

Another option if you want the same exact image on both languages you make the block untranslatable.

You need to also enable i18n_select if you have not done so and go to "detection and selection" admin/config/regional/language/configure and enable at least URL selection for interface/content

This will allow that when you visit yoursite.com/page assumes English and when you visit yoursite.com/LAN2/page assumes LAN2

More info on setting up internationalization

  • GiorgosK - Ok, I changed the block to be untranslatable, but it still only shows up when viewing the English version of the page. – matt Feb 6 '18 at 23:41
  • revised answer please check – GiorgosK Feb 7 '18 at 7:41
  • Thanks for helping with this GiorgosK - for "/admin/config/regional/language/configure" I currently have it URL enabled. All other content/menus switch languages without a problem - it is just this one block that seems to be disappearing when it should not. – matt Feb 7 '18 at 15:08
  • can you try to make it translatable and translate it and report back ? also if you have any extra modules please disable them at least temporarily, also report on any dblog messages (enable the module if its disabled) – GiorgosK Feb 7 '18 at 16:30
  • I made it translatable and translated - the translated version still did not show up. -And no related messages in dblog... – matt Feb 7 '18 at 20:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.