0

I am going through Drupal 8 theming with twig. It says to use "HTML no editor" text format for a custom block displaying font awesome links. There is no "HTML no editor" option, just basic HTML, restricted HTML, and full HTML. I am using the version Drupal 8.0.1 since that is the version needed for importing the database snapshots.

This is the code I am using for the links:

<ul class="social-icons">

  <li><a class="button--icon" target="_blank" 
  href="https://www.facebook.com/PacktPub" title=""><i class="fa fa-
  facebook"></i></a></li>

  <li><a class="button--icon" target="_blank" 
  href="https://www.linkedin.com/company/packt-publishing" title=""><i 
  class="fa fa-linkedin"></i></a></li>

 <li><a class="button--icon" target="_blank" 
  href="https://twitter.com/packtpub" title=""><i class="fa fa-twitter"></i>
 </a></li>

 <li><a class="button--icon" target="_blank" 
 href="https://plus.google.com/+packtpublishing/posts" title=""><i class="fa 
 fa-google-plus"></i></a></li>

</ul>

How do I get this code to display the font awesome links in a block? Why don't I have an "HTML no editor" option under text formats?

  • The phrase HTML no editor doesn't appear in Drupal 8's codebase (I just checked 5 separate installations with dozens of different contrib modules between them, not in any of them either). You'll have to ask the person who told you it should be there what they meant – Clive Feb 7 '18 at 20:14
  • Oh I just saw your version number - 8.0 is basically obsolete, maybe a format with that name existed back then. That info is a good couple of years out of date, finding a more up-to-date reference to learn from would be wise – Clive Feb 7 '18 at 20:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.