1

I have installed services module and added a service. And then, enabled the retrieve and index resources for node. I also enabled the permission to view the published content for anonymous users. cache is also cleared. When i call the retrieve or index service, i am getting the below response.

http://example.com/endpoint/node/1.json

Response:

["Access denied for user anonymous"]

Is there any thing i missed here?

Version D7 - Services 7.x-3.20

Update: It was issue with domain module. Domain strict module was enabled. After disabling, it started working.

  • Did you enable Session authentication under /admin/structure/services/list/[my-endpoint-name]? – tyler.frankenstein Feb 14 '18 at 14:19
  • Yes, session authentication is enable. But i found that the issue is with domain strict module which was enable in my site. I updated the question. Thanks. – Surendra Yellu Feb 16 '18 at 7:02
1

It was issue with domain module. Domain strict module was enabled. After disabling, it started working.

0

Make sure node/1 status must be published, otherwise you will get this error.

  • Yes, it is published node. – Surendra Yellu Feb 14 '18 at 10:48
  • I had simply installed the module and after end point creation enabled the node indexing and retrieving. It works fine without any issue. – Yogesh Kushwaha Feb 14 '18 at 13:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.