0

I can't understand how to install Owl Carousel module for Drupal 7.

I installed module from here - https://www.drupal.org/project/owlcarousel And downloaded additional files from here - https://owlcarousel2.github.io/OwlCarousel2/

Put this folder in "sites/all/libraries" and managed fields for my content type. I can see few images on my page, but carousel doesn't work.

Here is the error from chrome console - "Uncaught TypeError: o.owlCarousel is not a function" "GET https://mysite/owl.carousel.min.js?p44xlt net::ERR_ABORTED"

-1

Please check that you have installed jquery_update module.

  • Of Course. It's installed and enabled. I believe, that I can't enable Owl Carousel, if I don't have all needed modules enabled – Nikita Yunoshev Feb 14 '18 at 10:28
  • Have you checked the version of the jquery for front end should be greater then 1.9. – Chandraveer Feb 14 '18 at 10:31
  • Yeah it's greater than 1.9 I have found that carousel js trying to includes like this - "<script type="text/javascript" src="/owl.carousel.min.js?p44z30"></script>" Instead of "site/all/libraries/owlcarousel/dist/...". How can I fix that? – Nikita Yunoshev Feb 14 '18 at 10:48
  • You have to enable Library module. – Chandraveer Feb 14 '18 at 10:56
  • joxi.ru/5mdqoxWfvWyMN2 – Nikita Yunoshev Feb 14 '18 at 11:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.