0
  1. Create view.
  2. Select Format: Table.
  3. Under the Table Settings toggle Sortable on.
  4. Fields gets arranged/sorted unnaturally 1 2 3 4 40 5 50 51 6 60, etc. both ways ascending and descending.

enter image description here

The module Views Natural Sort does not solve the problem, it works only with fields under Sort criteria settings. And it's pretty broken in overall, the option to sort doesn't even appear in my Views.

We want to sort in normal natural way 1 2 3 4 5 6 7 8 9 10

0

Try to install Views_bootstrap module.

Then in views/Format select Bootstrap Table

Don't forget the Settings

  • Isn't this for bootstrap theme only. – user3108268 Feb 21 '18 at 10:33
  • Yes, if you're not using bootstrap theme then try with the settings in table Format Check Sortable - Default order and default sort – Baach Feb 21 '18 at 10:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.