I'm not sure if that was me messing around with Media, or is it Media's fault by de*fault*. I'm using that module mainly for its ability to re-use uploaded media, but for some reason I cannot get the images real preview. What is the crucial setting to have an image file display its preview in the library and in the content type editor?

I must say with more and more experience using Drupal, I'm still perplexed when it comes to configuring Media file types and display options. Seems like one could fall into an endless loop when trying to manage files' display options.

3 Answers 3


Are you saying that the thumbnail images for file uploads aren't displaying (a broken image icon the browser)?

If so, depending on how you installed Drupal ... drupal (well your webserver) needs to own the /sites/default/files/styles directory, or else drupal cannot create thumbnails for preview on-the-fly.

This is a known Issue: theme_image_style_preview() and image_requirements() should check whether style directories are writable.

  • The icons are "default" rather than broken. Each image icon has a yellowish sky with a bird and white sun against it. It is magnified from a low-res icon. My styles directory is writeable - tested with chmod 775 and 755. Mar 16, 2012 at 8:58

It may depend on your file system configuration (admin/config/media/file-system). If your site uses "private" file system you may meet Media "Known Issues" case.

If you have installed and use any other "stream wrapper" (you can see it in the list of choices in Download method section on the config page mentioned above), you may meet Image module problem - it can use either "public", or "private" file system for image styles.


OK, the answer is: I turned off the view mode named "Preview" in Media. As it turns out, the name is strongly recognized by the plugin and restoring the mode brought back the preview thumbnails. Thanks to Devin Carlson for providing support on that.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.