3

We have been using Drupal 6 for 2 years and we wanted to use SOLR to have a better search and index more documents.

I have did everything right with Apache Solr as per the documentation, my Solr was working fine but I am able to access it on http://localhost/solr/admin.

I have different Solr in different servers, and none work with this Drupal. So I think there is an inherent problem within Drupal, which makes drupal not to find the solr properly.

Previously, I had encountered this issue several times configuring different servers, I am used to reinstall Drupal which made solr work fine but I cant do it to this one because its been running for long with lot of content.

Can anyone help me?

3

There a lot of apache solr variables set. Can you uninstall the solr module, remove the variables if left over and re-install. Sometimes, when you do a wrong config and it can't connect, it presists this in variable. Un-installing and re-installing should help.

|improve this answer|||||
2

I follow this article https://www.lullabot.com/blog/article/installing-solr-use-drupal ,some day comes this errors after I reconfig of my site& apache. but I sloved like thisenter image description here

enter image description here

|improve this answer|||||
  • I don't want install apache tomcat, do you have a solution without install tomcat? – Yusef Jan 5 '16 at 10:06
2

If your site runs on Pantheon and you restored a database export from Pantheon in a local development environment, you have to disable the Pantheon Apache Solr module. It will not use the configured Solr URL if this module is running.

|improve this answer|||||
0

Belated answer:

check whether your Solr-serving process is running, and whether you are serving up Solr on the correct port.

The default Solr install seems always to come with Jetty (a Java based server) which runs on port 8983.

Solr can also be installed over Tomcat (another Java based server) which runs on port 8080.

Check if the process (whichever you chose - Jetty or Tomcat) is running, e.g.: ps -ef | grep tomcat

Your web logs may offer a clue.

|improve this answer|||||
0

for me this was happening due to an incorrectly set up core. what fixed it was, from shell on solr server, from within /opt/solr/bin:

 $ sudo -u solr ./solr create -c drupal

On Centos using solr 5.4.1, at least on my server, you must set the core up as the solr user. Solr won't let you write to the index if it's not set up correctly, or if you simply copy xml files out of one of the examples.

|improve this answer|||||
0

You just need to add your collection in solr by following the step given in this url ( Apache Solr 4.6.0 installation and compatibility with Drupal7... ) and then select your collection from your solr which is running on localhost or live site (http://localhost:8983/solr/) and go to schema tab. Click schema tab and then you can see you schema file attach in apachesolr module.

You now just need to your schema url which just look like this http://localhost:8983/solr/your_core_name/. Now add this url in apachesolr module.

Then it will show that your site has contacted apache solr server in your drupal site.

|improve this answer|||||

Not the answer you're looking for? Browse other questions tagged or ask your own question.