0

I am having a strange problem on my local dev site install. When either Basic HTML or Full HTML mode is selected in CkEditor, the toolbar and the whole area where text would be typed, are not available or visible. Yet when selecting Restricted HTML, the area for text and toolbar are visible and available.

This is the only user I have on my site so I am assuming it has full administrative privileges correct?

Where else do I need to change any settings for this user to have access and use Full or Basic HTML along with the toolbar?

The Text formats and editors section have Administrator under the Rolescolumn for Full HTML

Any ideas or suggestions of where I am going wrong?

Brand new Drupal user here, obviously.

Semi Reolved.. Found the issue for a temporary fix.. Status Report showed an error for a CodeTag module that was not loaded for some reason. Even though it was installed and enabled with drush. Even showed up in list from drush pm-list command so not sure what the deal is with it. Uninstalled it in UI on-site instead of with drush and the editor issues are no more. For what I originally posted.

0

Sounds like you have a ckeditor plugin conflict.

Your symptoms are typical what happens if there are for example a js error on a added ckeditor plugin.

Quick way to confirm is using Firefox Console, it will in most cases flag the offending js for you. Armed with that you can google for a fix or patch.

Alternatively you can turn of the plugins off one by one, but you need to remember to clear your cache, else the offending js could still be there.

So try FF console first and post any extra info you get.

1
  • Thanks for the info! I'll try that and also, I forgot about clearing the cache so going to do that for sure. Thanks
    – J2112O
    Mar 6 '18 at 10:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.