0

Am working with drupal7.When images are loading below error is showing in my test site console:

GET sites/default/files/styles/slideshow_full/public/plans/30989/main-image/contemporary_house_plan_westbrook_30-065_front.jpg?itok=TkUdCJQ5 403 (Forbidden)

When I paste the above URL in browser it is showing that "You are not authorised to access this page" error.

I checked all the permissions and all has 777. But the same functionality is working with my local site.Can anyone give me a suggestion to solve this issue?

0

This is a typical result of an incorrect url path.

That folder may/may not exist on the test server, but because it's outside of your user's folders, you 'don't have permission to access' it.

For example: Typical user's folders for cPanel are /home/USER/ with the site root at /home/USER/public_html. But, typical for a local machine is /var/www/....

So when you call sites/default/... from a local machine, it is possible that it's actually looking at /var/www/sites/default/.... When doing that on the test server, the path would be outside your user's folder and therefor no access permission.

It could be as simple as a missing ../ on your relative paths. So you could try 1. adding ../ to the start of your paths and see if that takes it to the correct location. or 2. Try explicitly setting the base url in your settings file $base_url = 'http://foobar.com'; to force a starting point for relative paths.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.