1

I've inherited a Drupal site and uploaded it to a new server but retained the existing domain name. The site is working, but when I try to log in as admin (or any other user) the login page just reloads with the username field highlighted red. There are no error messages and the username is definitely correct. I have tried to re-set the password manually in the database. I have also tried to add a new user directly into the database with admin privileges. Neither works. Also, there is no forgot password link on the login page. I have tried to change the base url and cookie url in the settings.php file but that did not work. I have tried repairing the sessions table but to no avail. I'm new to Drupal so not sure what to try next.

  • Is the system messages block being output, or $messages printed in the page template? – Kevin Mar 15 '18 at 15:38
0

Perhaps User 1 (if that's the admin login you're using) is blocked somehow. There could be a module, or custom code somewhere that is blocking this account's login.

I'd try looking through the list of contrib (contributed/non-core) modules for any who's name looks like it might be responsible for limiting login access.

Also, look for any custom modules and look through their code for any hints that it may be limiting logins also.

If you find a suspect then try disabling the module to see if this resolves the issue.

Another place to look for possible culprit code is in the active theme's template.php file (usually located in /sites/all/themes/THEME_NAME/template.php)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.