0

I need to translate part of a website. So I had enabled necessary modules : content translation, i18n + i18n sync. Then create some translation of 2 differents content type (after setting them to enable translation).

Put the Language switcher block active, and it appear on translatable contents. But when I want to switch, the link is good but system give me a 404.

In permission level, I see nothing to do .

What is missing in my settings ?

Thanks

0

Solution was here : https://drupal.stackexchange.com/a/150657/8753

For D6 the path is : admin/settings/language/edit/en

No need to set the prefix into the URL provided by pathauto here : admin/build/path/pathauto

in admin/settings/language/configure , both choice between Prefix only or Prefix and alternative solution seem to work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.