-1

We have installed Acquia lightning on the website.

We have updated the core only for past 1 year, unfortunately now we see lightning and Drupal not compatible in version point of view.

Now we got struck and we are not sure whether we update the lightning profile alone or downgrade Drupal.

Thanks, Kumaresan.G

  • The instructions on upgrading are in the Lightning docs – Kevin Mar 22 '18 at 13:11
0

we are not sure whether we update the lightning profile alone or downgrade Drupal

Definitely don't downgrade Drupal on account of Lightning. Lightning increments it's minor version when a minor version of core comes out. The most recent version is 3.1.x which is compatible with core 8.5.x. I suspect you have a constraint in your project's composer.json file which is preventing you from getting one of those. Something like the following should resolve your issue:

$ composer require drupal/core:~8.5.0 acquia/lightning:~3.1.0 --no-update
$ composer update

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.