4

I am trying to build the master branch in my project after updating to 8.5.0, but am being met with an error from composer (which I did not get on my develop branch):

The requested package drupal/focal_point 1.0.0-beta6 is satisfiable by drupal/focal_point[1.0.0-beta6] but these conflict with your requirements or minimum-stability.

In my composer file, I have:

"drupal/focal_point": "^1.0",

as well as:

"minimum-stability": "dev",

How can I fix this so TravisCI gets unstuck? It worked fine for the develop branch, and the master is now updated with it.

3
  • Have you tried composer prohibits drupal/focal_point?
    – sanzante
    Mar 26, 2018 at 14:22
  • The only output is acquia/blt-project dev-master requires drupal/focal_point (^1.0) where acquia/blt-project is the name in my main composer.json file.
    – Kevin
    Mar 26, 2018 at 14:24
  • Indeed it seems a problem with minimum stability. Make sure there're no stability requirements per package, like said in Composer doc (Note that you can also specify stability requirements on a per-package basis using stability flags in the version constraints that you specify in a require block (see package links for more details). See getcomposer.org/doc/04-schema.md#minimum-stability. I have no other ideas :(
    – sanzante
    Mar 26, 2018 at 14:46

1 Answer 1

3

This may be incorrect per information in comments and because it contradicts Installing an alpha dev version with composer.

I think the issue here is that the beta6 is not ^1.0. If you updated the requirement to be "drupal/focal_point": "^1.0@beta", this would work fine.

Alternatively, you could call composer require drupal/focal_point with no version specified and it would install the beta6 version just fine. I believe this is where minimum stability is checked, but that would add a require line in your composer.json different from what is specified in your question.

6
  • I also just added the specific version. Develop builds fine, master is still broken with the same error. I will try this.
    – Kevin
    Mar 26, 2018 at 15:31
  • This is interesting. I don't think your develop branch should not be building with the information you provided above. This sounds like an issue where develop is building something it shouldn't and master is acting appropriately.
    – sonfd
    Mar 26, 2018 at 15:38
  • Yeah its weird because it was working a week ago, I haven't changed anything about my process. On Friday I updated to Drupal 8.5.0, Drush 9, and BLT 9. Develop still worked, no problem. Now I am merging into master and thats what I see.
    – Kevin
    Mar 26, 2018 at 15:41
  • So I went the nuclear route, deleted the master branch, created a new one, and pushed it. Travis/Composer did not have an error at all. Very weird. The codebases are/were identical.
    – Kevin
    Mar 26, 2018 at 16:09
  • @Kevin - As sonfd said plus delete vendor and then reinstall.
    – leymannx
    Mar 26, 2018 at 16:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.