0

I am using Feeds and Feeds Tamper Find and Replace RegEx Plugin to import a few files to Nodes.

The importer has been mapped correctly, however, doesn't import any data. On each import I get the message, Imported Items, however, every node is empty.

I tried with UTF-8 encoding, ASCII as well as Auto, but nothing imports.

I am no developer and very new to RegEx, found out about it just last week, however, I tried to create a RegEx to pull in the just Title to see if it works. The RegEx code worked fine in Atom Text Editor, as well a couple of online RegEx Testing sites. Works alright. However, doesn't work in Drupal.

/^[A-Za-z]\w+\s[a-zA-z]\w+/

My Feeds Tamper Configuration -

REGEX to find: ^[A-Za-z]\w+\s[a-zA-z]\w+

Replacement pattern: $1

Limit number of replacements: 1

I did come across this question while searching for a solution, however, that didn't work either.

Please advice

Thanks

  • in mapping settings, map NID an set it to be unique, this may be the solution, it was for me in a commerce feed import. – pinueve Mar 26 '18 at 20:19
  • Thank You for the suggestion, however, it doesn't work in my case. The issue I believe is the RegEx code pattern and or replacement, the importer doesn't pick any details irrespective of the permutations and combinations. – Girish Cholayill Mar 27 '18 at 7:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.