1

I was following this video to add a contextual filter so the page I'm creating would display content created by the logged-in user only.

However, when I scroll down the list of contextual filters, I don't see the User: options. How can I see them? Am I missing some module or option? My Drupal 7 setup is almost all by default.

1

The tutorial you're watching is out of date (I watched it too); it was created when Views was in beta/RC and things have changed a bit since then.

You just need to add the user as a Relationship under the "Advanced" options...then you'll get the user filters as you'd expect.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.