0

I'm using webforms on Drupal 8.5.1 . I want to add some custom, arbitrary text to the form, so I chose to add a markup element. We want to have the text at the top of the form "Thank you for taking the time to fill out this survey. In order to serve you better..."

When the dialogue comes up, I see this:

enter image description here

From appearance and clicking, it seems like there is a missing textarea on the widget where I would enter the markup, right under the header "HTML markup".

I'm not sure if this is a problem with my install, my settings, or perhaps a bug.

I've looked at permissions and administrators have all webform permissions checked, and they are greyed out, so they can't be unselected. The account I'm using is an administrator account.

I am new to Drupal 8, and even more so its webforms. Is there something wrong in my settings?

  • Editable form field? You want textfield. – Kevin Mar 29 '18 at 19:04
  • @Kevin sorry, not a form field, but an uneditable message: "Thank you for taking the time to fill out this survey. In order to..." – user1359 Mar 29 '18 at 19:28
  • 1
    The missing edit is most likely a bug. @see drupal.org/project/webform/issues/2936147 – jrockowitz Mar 29 '18 at 19:30
1

The missing editor is most likely a bug. You should see what is being logged in the browser's JS console.

@see https://drupal.org/project/webform/issues/2936147

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.