1

I applied the patch from here: https://www.drupal.org/sa-core-2018-002 to my Drupal 7.53 site. I can't do a full upgrade as it might break stuff. The patch caused the following error as found in my httpd log file.

PHP Fatal error: require_once(): Failed opening required '/var/www/xxxxx/includes/request-sanitizer.inc' (include_path='.:/usr/share/pear') in /var/www/xxxx/includes/bootstrap.inc on line 2622

What could be wrong? The file does exist in that directory and this patch worked fine on another site I patched.

FYI, my server is on PHP 5.3.6

closed as off-topic by Clive Apr 2 '18 at 10:14

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This question was caused by a problem that can no longer be reproduced, was solved by a cache clear, or was a simple typographical error. While similar questions may be on-topic here, this one was resolved in a manner unlikely to help future readers." – Clive
If this question can be reworded to fit the rules in the help center, please edit the question.

  • I managed to get it working by copying the entire patch contents (request-sanitize.inc) into the bootstrap.inc file where it was being called. now the site is loading. but i still dont know why the require_once isn't. – Patoshi パトシ Apr 2 '18 at 6:13
  • 1
    It was likely a file permissions issue. – Jaypan Apr 2 '18 at 9:29
  • What should it be set as? 644? – Patoshi パトシ Apr 2 '18 at 21:59
  • Depends on your setup, permissions/groups Apache runs under and that your user has. – rovr138 Apr 3 '18 at 21:31

Browse other questions tagged or ask your own question.