2

Update from 8.5.0 to 8.5.1 is failing on one of my drupal instance.

>composer update drupal/core --with-dependencies
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - The requested package symfony/debug (locked at v4.0.6, required as ^3.4.0)
 is satisfiable by symfony/debug[v4.0.6] but these conflict with your 
requirements or minimum-stability.

What does this mean? What should I do?

PS: Please find below some more related information

>composer outdated
consolidation/output-formatters       3.1.13       3.2.0
dflydev/dot-access-data               v1.1.0       v2.0.0
drupal/core                           8.5.0        8.5.1
drupal/metatag                        1.4.0        1.5.0
egulias/email-validator               1.2.14       2.1.3
guzzlehttp/guzzle                     6.3.0        6.3.2
nikic/php-parser                      v3.1.5       v4.0.1
psy/psysh                             v0.8.17      v0.8.18
symfony-cmf/routing                   1.4.1        2.0.3
symfony/config                        v3.4.6       v4.0.6
symfony/console                       v3.4.6       v4.0.6
symfony/dependency-injection          v3.4.6       v4.0.6
symfony/event-dispatcher              v3.4.6       v4.0.6
symfony/filesystem                    v3.4.6       v4.0.6
symfony/finder                        v3.4.6       v4.0.6
symfony/http-foundation               v3.4.6       v4.0.6
symfony/http-kernel                   v3.4.6       v4.0.6
symfony/process                       v3.4.6       v4.0.6
symfony/routing                       v3.4.6       v4.0.6
symfony/serializer                    v3.4.6       v4.0.6
symfony/translation                   v3.4.6       v4.0.6
symfony/validator                     v3.4.6       v4.0.6
symfony/var-dumper                    v3.4.6       v4.0.6
symfony/yaml                          v3.4.6       v4.0.6
twig/twig                             v1.35.2      v2.4.7

composer.json file:

    "name": "drupal/drupal",
    "description": "Drupal is an open source content management platform powering millions of websites and applications.",
    "type": "project",
    "license": "GPL-2.0+",
    "require": {
        "composer/installers": "^1.0.24",
        "wikimedia/composer-merge-plugin": "^1.4",
        "drush/drush": "^9.2",
        "drupal/ctools": "^3.0",
        "drupal/devel": "^1.2",
        "drupal/ds": "^3.1",
        "drupal/conditional_fields": "^1.0@alpha",
        "drupal/field_group": "^1.0",
        "drupal/filefield_paths": "^1.0@beta",
        "drupal/bootstrap_layouts": "^5.1",
        "drupal/page_manager": "^4.0@beta",
        "drupal/page_manager_ui": "^4.0@beta",
        "drupal/magnific_popup": "^1.3",
        "drupal/config_update": "^1.5",
        "drupal/config_update_ui": "^1.5",
        "drupal/duration_field": "^1.1",
        "drupal/pathauto": "^1.1",
        "drupal/token": "^1.1",
        "drupal/metatag": "^1.4",
        "drupal/bootstrap": "^3.10",
        "drupal/features": "^3.7",
        "drupal/admin_toolbar": "^1.23",
        "drupal/linked_field": "^1.1",
        "drupal/core": "^8.5",
        "drupal/bootstrap_paragraphs": "^2.0@beta",
        "drupal/entity_reference_revisions": "^1.4",
        "drupal/paragraphs": "^1.2",
        "drupal/eva": "^1.3",
        "drupal/slick_views": "^1.0@RC",
        "drupal/yaml_editor": "^1.0"
    },
    "replace": {
    },
    "minimum-stability": "dev",
    "prefer-stable": true,
    "config": {
        "preferred-install": "dist",
        "autoloader-suffix": "Drupal8"
    },
    "extra": {
        "_readme": [
            "By default Drupal loads the autoloader from ./vendor/autoload.php.",
            "To change the autoloader you can edit ./autoload.php.",
            "This file specifies the packages.drupal.org repository.",
            "You can read more about this composer repository at:",
            "https://www.drupal.org/node/2718229"
        ],
        "merge-plugin": {
            "include": [
                "core/composer.json"
            ],
           ],
            "recurse": false,
            "replace": false,
            "merge-extra": false
        },
        "installer-paths": {
            "core": [
                "type:drupal-core"
            ],
            "modules/contrib/{$name}": [
                "type:drupal-module"
            ],
            "profiles/contrib/{$name}": [
                "type:drupal-profile"
            ],
            "themes/contrib/{$name}": [
                "type:drupal-theme"
            ],
            "drush/contrib/{$name}": [
                "type:drupal-drush"
            ],
            "modules/custom/{$name}": [
                "type:drupal-custom-module"
            ],
            "themes/custom/{$name}": [
                "type:drupal-custom-theme"
            ]
        }
    },
    "autoload": {
        "psr-4": {
            "Drupal\\Core\\Composer\\": "core/lib/Drupal/Core/Composer"
        }
    },
    "scripts": {
        "pre-autoload-dump": "Drupal\\Core\\Composer\\Composer::preAutoloadDump",
        "post-autoload-dump": [
            "Drupal\\Core\\Composer\\Composer::ensureHtaccess"
        ],
        "post-package-install": "Drupal\\Core\\Composer\\Composer::vendorTestCodeCleanup",
        "post-package-update": "Drupal\\Core\\Composer\\Composer::vendorTestCodeCleanup"
    },
    "repositories": {
        "0": {
            "type": "composer",
            "url": "https://packages.drupal.org/8"
        },
        "drupal": {
            "type": "composer",
            "url": "https://packages.drupal.org/8"
        }
    }
}
  • 2
    Can you also add your composer.json file? – Berdir Apr 2 '18 at 7:03
  • Added composer.json to the log – Sensimple Apr 2 '18 at 7:23
  • Anybody, any suggestions? I am stuck, I don't want to do the manual upgrade... – Sensimple Apr 3 '18 at 10:53
  • See drupal.stackexchange.com/questions/258940/…, you have basically the same problem as far as I see, you are mixing drupal/drupal and drupal/core – Berdir Apr 3 '18 at 13:03
  • Thanks @Berdir! Looks like I need to start from drupal-project as you suggested. – Sensimple Apr 3 '18 at 14:12
0

Try to delete the composer.lock file and try

composer update drupal/core --with-dependencies
| improve this answer | |
  • Not working! Your requirements could not be resolved to an installable set of packages. Problem 1 - The requested package symfony/debug (installed at v4.0.6, required as ^3.4.0) is satisfiable by symfony/debug[v4.0.6] but these conflict with your requirements or minimum-stability. – Sensimple Apr 2 '18 at 6:55
  • Can you try this composer update --with-dependencies drupal/core:~8.5 symfony/class-loader:~3.2.13 drush/drush:~9.@dev – Razeem Ahmad Apr 2 '18 at 6:58
  • where "drupal/core": "^8.x", is written in composer.json file. I think you should write it in require { "drupal/core": "^8.x", } part. – Razeem Ahmad Apr 2 '18 at 7:02
  • Composer.json is added to the quesiton. The above command still showing error. – Sensimple Apr 2 '18 at 7:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.