-2

I have a hard time convincing my staff that they can use Drush version 8.1.15 to work on D8 sites on 8.4.6 and later, because the Drush compatibility chart likely needs a new row between D8 and D9 for Drush 8.1.15+ to indicate it can work on D6, D7, D8, D8.4+

The compatibility chart at this location looks like its controlled by git, and I'm just not catching on how to "edit on GitHub". Can someone edit that chart please? I had a colleague update to Drush 9, and now he can't issue commands for Drupal 7 sites.

  • I'm voting to close this question as off-topic because it is a request that needs to be open in the appropriate issue queue. – kiamlaluno Apr 2 '18 at 20:05
  • Welcome to Drupal Answers! I am sorry, but this site is not to send requests to specific users (supposing those users have an account here). Open an issue on Github for Drush repository. – kiamlaluno Apr 2 '18 at 20:08
1

The compatibility table is given on http://docs.drush.org/en/master/install and if you believe something is incorrect on the table, then you must submit issue on https://github.com/drush-ops/drush/issues/new, so authorized users could edit the page.

However, I doubt anything is wrong on that table. And please also note if you install the Drush Launcher as suggested on http://docs.drush.org/en/master/install, then it will automatically load local environment for each Drupal website: Drush 9 for Drupal 8 websites and Drush 8 for Drupal 7 websites.

You might also be interested in reading How to get Drush to work with Composer

  • 1
    The table is wrong, Drush 8 works just fine with Drupal 8.4+. Doesn't change anything about the other part of the answer, this is a Q&A site, we can't answer that table into correctness – Berdir Apr 2 '18 at 20:10

Not the answer you're looking for? Browse other questions tagged or ask your own question.