0

I am using "Access by Term" configuration to control VIEW and UPDATE access for a content type with a Term Reference field in the content type. See screenshot.

But setting this configuration hides the term ref field in Node View.

How do I fix this?

screenshot of the term ref ABT config fieldset: enter image description here

1

Make sure to assign "Allow users to view ABT terms on node page." permission to desired roles.

  • Had completely forgotten about permissions page! Thanks for the answer – Maddy Apr 5 '18 at 6:19
-1

ABT is a bit treaky to configure, user and contentype must have in common same field TR and same TID on both, i think your problem is that your user do not have same TID (exacltly the same taxonomy and term, ABT looks for TID) and thats why your user do not have permission to see it or update it. Make sure you have same field settings on both sides, user and contentype. I recommend you to install devel and devel node access and there you can see exacltly who has or not permmisions on nodes, fields, etc.

  • I completely agree with you, configuration is so very simple but I still Took couple of hours to realize to use common same field under User profile and Content type! Thanks for the reply :) – Maddy Apr 5 '18 at 6:25
  • please explain why a have a down vote, even the person that palce the question agrees with me. – pinueve Apr 6 '18 at 23:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.