1

There is something strange it happened at a certain time. I no longer can set the text format from article (node) edit because the Text format input has dissapeared.

I can configure them from Configuration page but no longer can choose them from edit mode.

I have all permissions over them set up ok.

Please if you have any suggestions help me up.

enter image description here

Strangely, this combo dissapeared from admin/structure/types/manage/CONTENT_TYPE/fields/body as well

I tried to alter the content type filter using a module but no luck:

function MY_MODULE_form_alter(&$form, &$form_state, $form_id) { 

 $form['body']['und']['0']['#format'] = "full_html";

}
2
  • 1
    This normally happens when there is just an input format, or the user is allowed to use just an input format. Can you verify that is not the case?
    – apaderno
    Mar 19, 2012 at 15:16
  • No, there all 3 in place. Still not appears when I activate PHP input filter. Mar 20, 2012 at 7:33

1 Answer 1

1

I have experienced this issue when a rich-text editor is enabled. In my experience, the input format box reappears when the rich-text editor is disabled.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.