4

I remember that, in previous versions of the Search API and Search API Solr, by default not entering any search term would return the entire list of items.

I have tried with new empty Drupal 8.5.1 using Search API and Search API Solr, using the default configuration, with MariaDB and Postgresql, using the default view pages /search/content and /solr-search/content, but it shows an empty list and the message Please enter some keywords to search. message.

Does somebody know how to change it to the previous behavior to get again the whole list of elements when no search terms are used?

2
  • Remove the "required" status on the exposed filter?
    – Clive
    Commented Apr 10, 2018 at 15:23
  • I have the same issue,I removed the required status of the exposed filter,but still I get no results.Any help on this?
    – Dion
    Commented Dec 4, 2023 at 14:05

1 Answer 1

3

After trying everything that I could figure out, I have uninstalled the module, deleting all the views and installing it again and it works. No idea about what was happening sorry, but it work.


Finally thanks for some help I could understand what was happening :D The Filter Criteria Fulltext search was a Required, if you remove the checkbox then you will get the full list of items by default.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.