0

When I translate a node I want that node's path alias to be like it's source node's path alias.

So in the url pattern for the translation nodes I use the token:

[node:source:url:path]

which according to this thread should be fine. But, it actually generates the alias "/node-402-0", although the source node has a path like "/welcome".

I have the feeling that in the token module the wrong language is being looked into.

Am I missing something?

  • Can you not simply build the URL the same way as in the source node, eg something like [node:source:title] if the source pattern is [node:title]? – Alfred Armstrong Apr 13 '18 at 11:26
  • @AlfredArmstrong its never just the title, unfortunately. i have a lot of different patterns for the original english nodes, since i have a lot of different content types. it would be nice to then just tell all translation to just copy the alias :( – Alex Apr 13 '18 at 12:21
0

I think you can set the alias to not be translated in the the content language settings (Admin->Config->Regional->content language.

Under each content type there should be a url alias option. Unchecking this should make the alias the same for all languages.

  • unfortunately not. i do want some languages to have their own translated patterns, but some should not (like chinese shouldnt, but german should have own patterns) – Alex Apr 18 '18 at 9:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.