0

Using Drupal 8.6 here and going mad with this:

I installed Search API module that has Database Search and Database Search Default included.

I can't install Database Search Default for the following reason "Content type article not found. Database Search Defaults module could not be installed.

Content type page not found. Database Search Defaults module could not be installed.".

I don't know what content type article or content type page the message is referring to

Another strange thing that i noticed is that i am not able to preview fulltext with "expose filter to visitiors" on my view and also i can't see the block in my page tho i place it on block layout.

Can someone please tell me how do i display the block in the block layout?

Thank you for reading,

  • 1
    I think you need to ask separate questions for different topics. For the question in the title, did you try the advanced option "Exposed form in block:Yes"?. – 4k4 Apr 18 '18 at 13:06
  • I don't see why i need to do that. Yes i selected the option "Exposed form in block:Yes". – Marco Ferreira Apr 18 '18 at 13:08
0

Database Search Default module expects the page and article content types that exist with the Standard Drupal install. You should be able to recreate these content types (and then later delete them) if you want to install that module. You should create Page|page, Article|article and keep both with the default body field. I think that'll be enough to let you install the Database Search Default module and see the configuration. You'll probably want to remove the configuration for page and article from the search configuration before you delete the content types.

If you don't choose to expose your form in block than you cannot place the form as a block on a page. If you're search results view is a block then I believe choosing to expose the form as a block will not work at all. If you want to expose the view as a block, you'll want to be sure that "Exposed form in block: No." Alternatively, if you're view is a page and you want your form to be a block, "Exposed form in block: Yes" and make sure Ajax is not enabled. (Afaik, Exposed form in block and ajax are not compatible at this time.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.