2

As in my earlier environment I was running Drush 6 and Drush 8 together.

I need help with the Drush 8 and Drush 9 installation. Is there any possible way to achieve it?

I tried to do porting command following Porting Commands to Drush 9, without success.

Any help would be appreciated.

  • I posted an answer to your question, but I stil think you should edit your question and remove all/most of the info about how you did it earlier as it make the question hard to read. – hansfn Apr 26 '18 at 9:29
  • Did you even see before comments duplicate means when something was asked earlier and someone again in same context . Now if you use a bit of sense and compare the time these questions were asked you’ll get what is the duplicate meant – Prabhat Singh Feb 10 at 12:40
  • When a question was asked doesn't matter, if it is asking exactly what another question is asking. Since @leymannx thinks this question was already asked, he voted to close the question. The comment is automatically added; it's not something he posted. – kiamlaluno Feb 14 at 13:39
  • Yes, the key is that the other question has an upvoted and accepted answer. – leymannx Feb 14 at 13:44
1

Install Drush 8 by downloading the phar file as recommended in the documentation. Rename the phar file to drush8, not drush.

Install Drush 9 as recommened in the documentation. I strongly recommend to install Drush Launcher globally using a phar file as documented and only install Drush site local. This is very easy if you are already using Composer to maintain your Drupal site. If you aren't using Composer to maintain your site, you can just as well install Drush 9 globally using Composer and forget about Drush Launcher.

  • Well I don't think using Drush 9 globally is a best practice as it's not stable yet with Drupal 8.5.x and when I am doing in the way as documentation it worked but just alone . I want if I can run Drush 8 as global and Drush 9 simultaneously on Drupal 8.5.x. – Prabhat Singh Apr 26 '18 at 10:18
  • Sorry, but I don't get what you are trying saying. The Drush developers recommends Drush 9 for Drupal 8.4 and newer. It's stable. In my answer you are able to run both Drush 8 and 9. (The discussion about local and global is related to installing with Composer.) Maybe you should clarify your question if my answer isn't what you are after. – hansfn Apr 26 '18 at 11:29

Not the answer you're looking for? Browse other questions tagged or ask your own question.