0

I am using the countries module to add countries in my content type project.

I create a view with type = Default node index to display my content.

I added the Indexed Nœud: Countries (Countries)

But the data saved in my field_countries is not displaying yet it is displayed well in the details page (node project).

Any idea to display the countries data in my view?

Thank you

  • @a-sana I haven't tried this module, but on its project page it says you need to add a Relationship Field: Country (field-country). After that you can add a field showing countries, this field must use the Relationship you created in order to show the countries. – prkos Apr 27 '18 at 0:19
  • @prkos, thanks for response, I added the relationship but nothing was changed – A.Sana Apr 27 '18 at 9:44
  • @a-sana adding a Relationship only opens the possibility for that View to add more fields and filters, it doesn't happen automatically. After you add the Relationship, you also need to add a new Field called Countries. Did you do those 2 steps listed on the module project page? – prkos Apr 27 '18 at 13:49
0

While adding relationship with countries, the most important, Check the checkbox Require this relationship and then add Countries: Name as fields you want.

It works for me (see) and hope for you too

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.