1

I am on drupal 7.56.

Something really disturbing happens.

I have created a custom content type named "Information" that uses the default body field. I granted access to this content to Administrator and to a newly created role that is "editor".

I made wrights configuration for both roles :

  • "Editor" and "Administrator" can "Edit own, Edit any" information ;
  • "Editor" and "Administrator" can "Edit own, Edit any" field body for that Information content type.

But only "Administrator" sees the body field in editing mode.

I am also using field_permission and content_access modules to make sure everything is fine in detail.

Still the same. On any browser, "Administrator" can see the body in edit mode but not the editor. Notice that body field text shows normally when displaying the node(s).

A help will be welcome!

closed as off-topic by Beebee, DRUPWAY, Neograph734, mradcliffe, leymannx May 14 '18 at 22:01

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This question was caused by a problem that can no longer be reproduced, was solved by a cache clear, or was a simple typographical error. While similar questions may be on-topic here, this one was resolved in a manner unlikely to help future readers." – Beebee, DRUPWAY, Neograph734, mradcliffe, leymannx
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Sounds like you may have configured a filter that is not available to the editor. So, for example, the filter set on the body field is "Full HTML" but the editor does not have permission to use it. – Alfred Armstrong May 2 '18 at 12:33
  • I have granted permission for user "Editor" to have access on "filtered HTML" option. I did that in "admin/config/content/formats". – mosgeorges May 2 '18 at 12:50
  • I did that a few day ago. But it didn't change anything. – mosgeorges May 2 '18 at 12:53
  • You are at least 3 critical security updates behind. You should upgrade to 7.59 – Beebee May 2 '18 at 13:27
  • Yeah like, forget this issue, and get updated. Beyond that, there is something about that text format that the user does not have permission to use. You also haven't specified which text format it is in the question. – Kevin May 2 '18 at 13:29
0

The commonest reason for this problem (and OP has confirmed it in this case) is as follows.

  1. The field that is inaccessible to some users has a filtered text format
  2. The formats that can be set on that field include one or more that are not permitted to all users (typically "full html")
  3. The content item in question has been edited by a user that has access to the restricted format and they have saved it with the field set to that format.
  4. Now only users that have that privilege can edit the item because that field won't load for those who don't.

The solution is for a privileged user to edit the item and change the format and save it again, though that may result in the HTML changing in a way that's undesirable. If the item needs "special" HTML then it may not be possible for it to be maintained by the less privileged users.

Not the answer you're looking for? Browse other questions tagged or ask your own question.