0

I am fairly new to Drupal.

I just got an already existing Drupal project and want to install it.

I copied it to: /var/www/html/myprojects/mydrupalproject

Then I got this error in my error.log from apache2:

[Thu May 03 17:55:41.603774 2018] [php7:notice] [pid 11604] [client 127.0.0.1:41930] PHP Notice: Constant DATE_RFC7231 already defined in /var/www/html/myprojects/mydrupalproject/includes/bootstrap.inc on line 258, referer: http://127.0.0.1/myprojects/

[Thu May 03 17:55:41.604601 2018] [php7:error] [pid 11604] [client 127.0.0.1:41930] PHP Fatal error: require_once(): Failed opening required '/var/www/html/myprojects/mydrupalproject/profiles/clusters_public/modules/contrib/apc/drupal_apc_cache.inc' (include_path='.:/usr/share/php') in /var/www/html/myprojects/mydrupalproject/includes/bootstrap.inc on line 2632, referer: http://127.0.0.1/myprojects/

So I tried to use the original .htaccess info in case it was the problem but I still get exactly the same error in the log. Any help?

  • Looks like you have PHP7. What version is your Drupal 7? Also check to make sure the filesystem permissions are set correctly so that www-data (or whatever user your webserver is running as) has read/write permissions on the codebase. Failed opening required ... usually means file permission issues or the file doesn't actually exist. – Beebee May 3 '18 at 17:47
1

Few things to check 1- Check what PHP version on your server, you will need PHP 5 not PHP 7.

2- Make sure you update the $base_url in you settings.php file, assuming you copied that from your local

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.