0

When migrating from Drupal 6 to 8 i can simply map path aliases with the mapping:

process:
  path: alias

I have the problem that the path alias is not set properly when pathauto is activated for a node-type. The alias always gets generated automatically instead of using the old alias. How can I override this behaviour?

1

You need to explicitly disable pathauto in your migration:

process:
  path/alias: alias
  path/pathauto:
    plugin: default_value
    default_value: false
0

For 8.5.6 Core is working fine. Another way for pathauto is:

path/alias: path_alias
path/pathauto:
    plugin: default_value
    default_value: 0

Regards! :D

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.