0

I have a small problem when translating taxonomy terms inside of a block view.

View configuration: View configuration

Output:

Front end output

The translation is correct but the element quantity is incorrect. The idea is to have one of each term in each block regardless of translation.

1
  • What terms do you see listed for that Vocabulary when you go to Structure > Taxonomy > [VocabName]? Maybe you have more than one term with the same name, only different term ID?
    – prkos
    May 9, 2018 at 23:15

1 Answer 1

2

You have to add a filter:

FILTER CRITERIA

Taxonomy Term: Translation language (= Content language selected for page)

or if the content language is not available when configuring the filter:

Taxonomy Term: Translation language (= Interface text language selected for page)

Otherwise you get a row for each translation, which are then all rendered in the same language, the one of the page, because you have configured this in the section Language in the middle column of the View.

1
  • 1
    There is also a second option, depending on what you want. This will only show translated terms. If you want that, great. If you want to see all terms, but no duplicates, and untransalted terms showing as a fallback language, then you can use a filter for it being the original language and change the language render option to use the interface language instead, which will then use that if available and if not, fall back to the second-best available translation
    – Berdir
    May 10, 2018 at 8:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.