Drupal 8.5.3, all modules and themes up to date.

The CKEditor only shows up for administrator users when creating or editing nodes. The authorized users are listed as Roles for the Text Format "Basic HTML" which is the Text Format for the field in the Content Type too.

There is a javascript error being thrown in /core/modules/ckeditor/js/cheditor.js, line 134 saying "drupalSettings.ckeditor" is undefined.

Thanks, Greg

2 Answers 2


It's fixed!

Turns out it was a problem (errant quote) in html.html.twig that was breaking document.querySelector in drupalSettingsLoader.js so nothing in drupalSettings was defined...


it would be helpful if you could share a screenshot. However, if you have not yet done so, verify that the CKEditor's permissions are enabled for that role and be sure to also verify the permissions of the directory where the module is located.

  • Thanks for the reply. The module's directory permissions are the same as all the other modules in core. There's nothing in /admin/people/permissions that I can see that's related to the CKEditor. But, yes, /admin/config/content/formats/manage/basic_html has the user role in question checked. What screenshot can I post that would help? May 15, 2018 at 13:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.