0

I installed the redirect Module in Drupal 8 but sorrily can't get it to work properly. I enabled all checkboxes in the settings, also the "Enforce clean and canonical URLs" option.

In my page source, the canonical is printed in a meta tag. But if I browse my page and enter a system URL like www.domain/node/5, no redirect to the autopath alias / canonical happens.

enter image description here

Does anyone have any suggestions? I also reinstalled it twice already. Nothing helped.

  • Have you tried completly wiping cache? I had the same problem until I did a drush cr on command line – Hudri May 15 '18 at 10:17
  • I just cleared the cache in the Backend UI, as this Drupal site sorrily doesnt have drush installed. Is there any possibility to wipe the cache completely without drush? – арно нюм May 15 '18 at 10:40
  • Clearing cache via Development > Performance is the same as full wipe via drush cr. If that didn't help it is a different problem. – Hudri May 15 '18 at 11:10
  • Perhaps this needs to be implemented to get the features you need working: Merge global redirect functions into Redirect module. – prkos May 15 '18 at 18:03
  • Thanks @prkos, but this was only neccessary, before global redirects was merged with redirect module. The Drupal 8 version is a combination of those two modules. Anyways thanks - I already found out why it didn't work. – арно нюм May 15 '18 at 19:50
0

LEL - it's so stupid, I have to clarify this. The redirect module works without any problem. Everything's just like I wanted it. Maybe it's pointed out anywhere, but I didn't read it.

When the page is set to maintenance mode, it doesn't work. I have some dummy-users that can bypass the "maintenance-page" and use the site. While the site is in maintenance mode, the node/IDs are accessible. When I turned off maintenance mode, the module was redirecting...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.