1

When I run composer require drush/drush

It gives below error

Using version ^9.3 for drush/drush
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Conclusion: don't install drush/drush 9.3.0
    - Conclusion: remove symfony/var-dumper v4.0.6
    - Installation request for drush/drush ^9.3 -> satisfiable by drush/drush[9.3.0, 9.x-dev].
    - Conclusion: don't install symfony/var-dumper v4.0.6
    - drush/drush 9.x-dev requires symfony/var-dumper ~2.7|^3 -> satisfiable by symfony/var-dumper[2.7.x-dev, 2.8.x-dev, 3.0.x-dev, 3.1.x-dev, 3.2.x-dev, 3.3.x-dev, 3.4.x-dev, v2.7.0, v2.7.0-BETA1, v2.7.0-BETA2, v2.7.1, v2.7.10, v2.7.11, v2.7.12, v2.7.13, v2.7.14, v2.7.15, v2.7.16, v2.7.17, v2.7.18, v2.7.19, v2.7.2, v2.7.20, v2.7.21, v2.7.22, v2.7.23, v2.7.24, v2.7.25, v2.7.26, v2.7.27, v2.7.28, v2.7.29, v2.7.3, v2.7.30, v2.7.31, v2.7.32, v2.7.33, v2.7.34, v2.7.35, v2.7.36, v2.7.37, v2.7.38, v2.7.39, v2.7.4, v2.7.40, v2.7.41, v2.7.42, v2.7.43, v2.7.44, v2.7.45, v2.7.46, v2.7.47, v2.7.48, v2.7.5, v2.7.6, v2.7.7, v2.7.8, v2.7.9, v2.8.0, v2.8.0-BETA1, v2.8.1, v2.8.10, v2.8.11, v2.8.12, v2.8.13, v2.8.14, v2.8.15, v2.8.16, v2.8.17, v2.8.18, v2.8.19, v2.8.2, v2.8.20, v2.8.21, v2.8.22, v2.8.23, v2.8.24, v2.8.25, v2.8.26, v2.8.27, v2.8.28, v2.8.29, v2.8.3, v2.8.30, v2.8.31, v2.8.32, v2.8.33, v2.8.34, v2.8.35, v2.8.36, v2.8.37, v2.8.38, v2.8.39, v2.8.4, v2.8.40, v2.8.41, v2.8.5, v2.8.6, v2.8.7, v2.8.8, v2.8.9, v3.0.0, v3.0.0-BETA1, v3.0.1, v3.0.2, v3.0.3, v3.0.4, v3.0.5, v3.0.6, v3.0.7, v3.0.8, v3.0.9, v3.1.0, v3.1.0-BETA1, v3.1.0-RC1, v3.1.1, v3.1.10, v3.1.2, v3.1.3, v3.1.4, v3.1.5, v3.1.6, v3.1.7, v3.1.8, v3.1.9, v3.2.0, v3.2.0-BETA1, v3.2.0-RC1, v3.2.0-RC2, v3.2.1, v3.2.10, v3.2.11, v3.2.12, v3.2.13, v3.2.14, v3.2.2, v3.2.3, v3.2.4, v3.2.5, v3.2.6, v3.2.7, v3.2.8, v3.2.9, v3.3.0, v3.3.0-BETA1, v3.3.0-RC1, v3.3.1, v3.3.10, v3.3.11, v3.3.12, v3.3.13, v3.3.14, v3.3.15, v3.3.16, v3.3.17, v3.3.2, v3.3.3, v3.3.4, v3.3.5, v3.3.6, v3.3.7, v3.3.8, v3.3.9, v3.4.0, v3.4.0-BETA1, v3.4.0-BETA2, v3.4.0-BETA3, v3.4.0-BETA4, v3.4.0-RC1, v3.4.0-RC2, v3.4.1, v3.4.10, v3.4.11, v3.4.2, v3.4.3, v3.4.4, v3.4.5, v3.4.6, v3.4.7, v3.4.8, v3.4.9].
    - Can only install one of: symfony/var-dumper[2.7.x-dev, v4.0.6].
    - Can only install one of: symfony/var-dumper[2.8.x-dev, v4.0.6].
    - Can only install one of: symfony/var-dumper[3.0.x-dev, v4.0.6].
    - Can only install one of: symfony/var-dumper[3.1.x-dev, v4.0.6].
    - Can only install one of: symfony/var-dumper[3.2.x-dev, v4.0.6].
    - Can only install one of: symfony/var-dumper[3.3.x-dev, v4.0.6].
    - Can only install one of: symfony/var-dumper[3.4.x-dev, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.7.0, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.7.0-BETA1, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.7.0-BETA2, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.7.1, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.7.10, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.7.11, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.7.12, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.7.13, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.7.14, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.7.15, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.7.16, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.7.17, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.7.18, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.7.19, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.7.2, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.7.20, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.7.21, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.7.22, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.7.23, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.7.24, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.7.25, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.7.26, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.7.27, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.7.28, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.7.29, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.7.3, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.7.30, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.7.31, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.7.32, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.7.33, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.7.34, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.7.35, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.7.36, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.7.37, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.7.38, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.7.39, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.7.4, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.7.40, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.7.41, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.7.42, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.7.43, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.7.44, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.7.45, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.7.46, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.7.47, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.7.48, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.7.5, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.7.6, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.7.7, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.7.8, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.7.9, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.8.0, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.8.0-BETA1, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.8.1, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.8.10, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.8.11, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.8.12, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.8.13, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.8.14, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.8.15, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.8.16, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.8.17, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.8.18, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.8.19, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.8.2, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.8.20, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.8.21, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.8.22, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.8.23, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.8.24, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.8.25, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.8.26, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.8.27, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.8.28, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.8.29, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.8.3, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.8.30, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.8.31, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.8.32, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.8.33, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.8.34, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.8.35, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.8.36, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.8.37, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.8.38, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.8.39, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.8.4, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.8.40, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.8.41, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.8.5, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.8.6, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.8.7, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.8.8, v4.0.6].
    - Can only install one of: symfony/var-dumper[v2.8.9, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.0.0, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.0.0-BETA1, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.0.1, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.0.2, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.0.3, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.0.4, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.0.5, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.0.6, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.0.7, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.0.8, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.0.9, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.1.0, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.1.0-BETA1, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.1.0-RC1, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.1.1, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.1.10, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.1.2, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.1.3, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.1.4, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.1.5, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.1.6, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.1.7, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.1.8, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.1.9, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.2.0, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.2.0-BETA1, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.2.0-RC1, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.2.0-RC2, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.2.1, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.2.10, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.2.11, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.2.12, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.2.13, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.2.14, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.2.2, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.2.3, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.2.4, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.2.5, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.2.6, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.2.7, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.2.8, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.2.9, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.3.0, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.3.0-BETA1, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.3.0-RC1, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.3.1, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.3.10, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.3.11, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.3.12, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.3.13, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.3.14, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.3.15, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.3.16, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.3.17, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.3.2, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.3.3, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.3.4, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.3.5, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.3.6, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.3.7, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.3.8, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.3.9, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.4.0, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.4.0-BETA1, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.4.0-BETA2, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.4.0-BETA3, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.4.0-BETA4, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.4.0-RC1, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.4.0-RC2, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.4.1, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.4.10, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.4.11, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.4.2, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.4.3, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.4.4, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.4.5, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.4.6, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.4.7, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.4.8, v4.0.6].
    - Can only install one of: symfony/var-dumper[v3.4.9, v4.0.6].
    - Installation request for symfony/var-dumper (locked at v4.0.6) -> satisfiable by symfony/var-dumper[v4.0.6].


Installation failed, reverting ./composer.json to its original content.

How to fix it?

  • Where are you trying to install drush ? On your local machine ? Anyway, it's better to install it globally => composer global require drush/drush – pbonnefoi May 31 '18 at 8:30
  • Yes locally on project – Test May 31 '18 at 9:43
  • Your project has symfony/var-dumper locked at 4.0.6, while drush requires ~2.7|^3 (i.e. a previous version). You need to resolve that conflict to continue, use composer why symfony/var-dumper to identify the problem – Clive May 31 '18 at 10:01
  • @Clive it gives psy/psysh v0.8.17 requires symfony/var-dumper (~2.7|~3.0|~4.0) – Test May 31 '18 at 10:14
  • There you go then, you need to reinstall psy/psysh with a lower version of symfony/var-dumper. Personally I prefer to start again when my projects get in this sort of muddle, it can be difficult to manually unpick it – Clive May 31 '18 at 10:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.