-2

I installed https on my server with certbot and let's encrypt.However site displays garbled under https, which I need for several reason, http requests are not redirected to https for that reason, but you can type it in address bar: https://demoflorida.com

0

This is kind of a duplicate of issues like Drupal not loading theme CSS with HTTPS.

@bharate is correct about the issue being caused by your assets not being loaded over HTTPS.

It's likely caused by the $base_url in settings.php.

Check to see if it includes the http protocol, and then replace it with something like:

$base_url = (drupal_is_https() ? 'https' : 'http') . '://www.example.org';

or

$base_url = '//demoflorida.com';

Using just // is protocol agnostic, so it will use whatever is asked for without any logic needed.

-1

Actually this is a problem of trying to load resources via http over https. You can check the link below for your website and you will see which elements/css are loaded via http You will have to call them with https and your page should be fine.

https://www.whynopadlock.com/results/09ff9e5c-52d1-4299-80e5-3db45fe3aafd

  • You can equally check this in the browsers inspector, which will be showing errors in the console. But knowing that the assets aren't being requested with the right protocol doesn't explain why Drupal is doing it. – mediaashley Jun 6 '18 at 9:34
  • this is the key to the question, why is drupal requesting all these URLs over http? i got all those errors, hard errors, testing over whyno padlock, anybody can replicate this by invoking the site over https:// – ckosloff Jun 7 '18 at 4:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.