0

I want to upgrade Commerce Kickstart (commerce_kickstart-7.x-2.53) to the latest 2.54. Following the upgrade instructions I went to the Structure Features menu to check for overrides and found these are overriden.

Commerce Kickstart Blog
Commerce Kickstart Lite Product
Commerce Kickstart Merchandising
Commerce Kickstart Slideshow
Commerce Kickstart User

But when I go to Review Overrides, I get these errors.

Notice: Array to string conversion in features_override_features_export_render_addition() (line 428 of /home/-----/public_html/sw/profiles/commerce_kickstart/modules/contrib/features_override/features_override.export.inc).
Notice: Array to string conversion in features_override_features_export_render_addition() (line 428 of /home/-----/public_html/sw/profiles/commerce_kickstart/modules/contrib/features_override/features_override.export.inc).
Error: Call to a member function stateVariables() on string in RulesPlugin->availableVariables() (line 740 of /home/-----/public_html/sw/profiles/commerce_kickstart/modules/contrib/rules/includes/rules.core.inc).

First, is there a fix for these errors?
If not, is there any way to know what overrides are actually in place?
In any case, can I proceed with the Commerce Kickstart (commerce_kickstart-7.x-2.54) upgrade?

FYI: Running Drupal 7.58 and PHP Version 7.1.16

Thanks

  • Workaround is to click on the feature name and it lists all settings for that feature, then Review Overrides gives changes for that feature so I have been able to print the list of changes for each feature. – ericrross Jun 12 '18 at 1:16
0

Are you sure those modules are compatible with PHP 7? We haven't tested nor do we recommend running Commerce Kickstart 2.x in PHP 7 as far as I know.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.