0

I'm using WYSIWYG Module with ckeditor as an editor.
I use it with the full_html format

My problem is that when switching from the rich-code to the source code view all the line breaks are removed.

So this portion of code :

<div class="highlight">
    <p>Nemo enim <a href="#">ipsam voluptatem quaerat voluptatem.</a></p>
</div>
<div class="body">
    <p><strong>Doloremque laudantium,</strong> totam rem aperiam, eaque ipsa quae ab illo inventore veritatis et quasi architecto beatae vitae dicta sunt explicabo.</p>
</div>

transforms into something like this :

<div class="highlight"><p>Nemo enim <a href="#">ipsam voluptatem quaerat voluptatem.</a></p></div><div class="body"><p><strong>Doloremque laudantium,</strong> totam rem aperiam, eaque ipsa quae ab illo inventore veritatis et quasi architecto beatae vitae dicta sunt explicabo.</p></div>

Is there a configuration that prevents this from happening ?

1

I think what you are looking for is WYSIWYG Linebreaks.

  • Thank you ! Exactly what i needed. If someone needs this, you need to install the WYSIWYG Linebreaks module then enable Force Linebreaks in the Buttons & Plugins at : admin/config/content/wysiwyg/profile/full_html – NSTK Jun 13 '18 at 22:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.