0

I use Acquia Dev Desktop2 on Mac for php7.0. I think that it is the previous version. I was waiting for the upgrade to use php7.1, but there was no announcement in check for update menu. I have no choice, so I downloaded it and overwrite install. The bad request will be displayed on all local sites. Phpmyadmin of all sites will be displayed correctly. What is the solution?

What I can think of is using underscores for site addresses.

test_drupal8_mockup1.dd:8083

In order to remove the underscore, I edited vhosts.conf and restarted apache. 'But request' was not improved.

  • After rewriting ServerName in vhosts.conf, and I restart Acquia Dev Desktop 2 App, ServerName will be restored. Which file should I edit to change ServerName? – Smokey Blues Jun 17 '18 at 14:11
0

As an alternative solution, I tried to add the following setting setting to httpd.conf.

<IfVersion> = 2.4.25>
 HttpProtocolOptions unsafe
</ IfVersion>

'Bad request' message is solved. The reason was that ServerName contained underscores.

Not the answer you're looking for? Browse other questions tagged or ask your own question.