0

enter image description hereIn Drupal 8.5.X I see that the session cookie is only HTTPOnly and not secure. Any idea how to enforce the session cookie to be always secured?

closed as unclear what you're asking by Kevin, Pierre.Vriens, DRUPWAY, leymannx, mradcliffe Jul 9 '18 at 0:32

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

2

The HTTP flag is being set by your browser as you're accessing Drupal over HTTP (and thus vulnerable to cookie hijacking). Drupal creates 2 different cookies (an unsecure HTTP one, and a secure HTTPS one) depending on what protocol it detects.

If you want only secure sessions, force HTTPS at the web server or application level (depending on your stack configuration).

Not the answer you're looking for? Browse other questions tagged or ask your own question.