2

I created a custom Content Type called "Event". In it, I use a custom "Date" field (from the Date module). When I try to create a View that displays all of the Events sorted by their Date, I can do this. However, when I try to add a field for "Date" so that I can display it in the output, "Date" is not shown in the list of fields. Is this because not all content types have a "Date" field? How can I get around this?

  • So you have a view that shows multiple content types and you wish to display a custom date field only on content of type event? Or do you have a view of events that you want to display your custom date field on? – Patrick Kenny Mar 25 '12 at 2:00
  • Do you have the date_views module enabled? – David Watson Mar 25 '12 at 2:26
  • I have a problem with this too. Pre-existing content type with a date field and the field refuses to come up as an option. Seems to be working for some people so there must be something triggering this as a bug. My date is stored in ISO format, not sure if this would make a difference. – contrebis Mar 18 '13 at 23:24
1

I'm not sure why you're having trouble. I just did this and it worked. Here's what I did.

  1. Add a "Date" field (widget: select list) to Content Type A.
  2. Create a view that shows items of Content Type A.
  3. Click Add next to Fields and search for the label for my "Date" field.

You should try looking through/searching your list of fields again. It should be there. (Even when a view is filtered to a specific content type, the Views module will often allow you to select fields that are not associated with that content type.)

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.