We realized that our Drupal core version is outdated by two versions. We are currently running 8.5.3, but 8.5.5 has been released. Rather than updating directly two versions, we wanted to upgrade from 8.5.3 to 8.5.4 and then eventually from 8.5.4 to 8.5.5.

We tried the following but it didn't get updated.

composer update drupal/core:8.5.4 --with-dependencies

Message after running composer command

Nothing to install or update

I ran this command in the directory outside of docroot in C:\users\name\Sites\mysite\ which has the following folders

  1. .git
  2. config
  3. docroot
  4. drush
  5. hooks
  6. vendor

I also ran composer why-not drupal/core:8.5.4 and had the following message returned.

There is no installed package depending on "drupal/core" in versions not matching 8.5.4

  • That is the correct command, did you run the command inside the Drupal root folder?
    – No Sssweat
    Jul 19, 2018 at 1:15
  • Along with confirming where you are running this, what is the output of composer why-not drupal/core:8.5.4 ?
    – mpdonadio
    Jul 19, 2018 at 2:34
  • 2
    Bear in mind that this is expected behaviour unless you actually used Composer to install drupal/core in the first place (whether that was manually or via the drupal project or whatever). So if your composer.json doesn't contain "drupal/core" under "requirements", you need to update your core manually, or convert it to a "proper" Composer workflow
    – Clive
    Jul 19, 2018 at 8:56
  • @NoSssweat I have updated the question to describe where i am running the command. Jul 19, 2018 at 17:13
  • @Clive i checked the composer.json file and it has "drupal/core": "^8.4" under require. Jul 19, 2018 at 17:19

2 Answers 2


After running composer why-not drupal/core:8.5.4 and doing some more research on the error message, I came across Upgrading from 8.5.0 to 8.5.1 using composer

This command did the trick for me.

composer require drupal/core:8.5.4  webflo/drupal-core-require-dev --update-with-dependencies

Look at your composer.json... do you see drupal/core listed under "require" or "replace"? Make sure you move it under "require"

  • Yes, I saw this exact same thing the other day on a project so can confirm. Jul 19, 2018 at 16:21
  • 1
    @bleen "drupal/core": "^8.4" is under require, but still having the issue. Jul 19, 2018 at 17:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.