0

I'm experiencing a bunch of oddities related to Views 3.3 (D7.12). This makes me wonder whether I run short of Views education or it's just an oddity of my installation. Let me list the annoyances:

  1. A title set up for a View (page display) won't show up in the output. Not even in the markup. Another - very similar view, row-themed as well, does not suffer from that.
  2. A view with exposed filter has two header Global: Text fields - set up to display: one with empty results, the other - for non-empty results only. Neither will ever show up.
  3. The same view has a Global: Result summary field, set to display @total of result set. To no avail. (I know there are raw PHP ways to do that, but why resort to raw code if there's a built-in feature supposed to do just that.)

none of these views uses aggregation or grouping, pretty I have googled and searched through Drupal Answers almost all last night long and did not find a working answer. Anyone been hit by any of the above?

My understanding is that if I use a row-style theming with tpl files like: views-view-fields--[view-name]--page.tpl.php, I'm only making myself responsible for the "foreach" part of the output, and the global fields (title, header, footer) should be rendered by the core Views engine. To verify, I tried to remove the tpl file, rescan, flush cache - the global fields did not show up whatsoever.

So, what is the secret...?

  • Did you by any chance upgrade Views without upgrading Ctools ? – Countzero Mar 27 '12 at 15:25
  • Well, a good point, I sync'ed the versions, which eliminated some ajax-related cosmetic problems, but none of the above. :( – Artur Mar 27 '12 at 16:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.