0

I'm trying to find a way to copy nodes (plus associated images) and (ideally) users from a Drupal 7 staging site into production.

In theory, this "Deploy - Content Staging" module is perfect:

https://www.drupal.org/project/deploy

In practice, I'm finding that managed images embedded in Media fields do not copy across.

The Deploy module will automatically copy across managed images embedded in an image field and even managed images embedded in body HTML which is impressive.

Unfortunately, almost all our managed images are embedded in Media fields.

I posted a detailed issue on Deploy here a few days ago:

https://www.drupal.org/project/deploy/issues/2987019

However, no one has been able to help me.

Any recommendations how I can copy nodes and associated images using the Deploy module? Failing that should I look at node export?

Thanks.

Regards Brett Sh

  • Have spent more time on this issue, but to no avail. I just can't get Media images added to the node dependencies in the deployment plan. Just to confirm an assumption, Deploy does support Media 7.2.x right? Had a quick scan thru the code, but couldn't pinpoint where exactly where images should be added to dependencies. Can anyone suggest a function to inspect? Is there anything I can do with a bit of custom code to force the dependency? Thanks Regards Brett – Brett S Jul 24 '18 at 22:47
  • Could the issue be something to do with a lack of UUID as described here: drupal.org/project/media/issues/1515788 Incidentally, I've tried installing the patch, but that didn't help either. – Brett S Jul 27 '18 at 5:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.