0

I'm using Drush 9.3 and when I export config it wants to create config files for modules that have been gone for months. One of those is plupload which is nice because it's easy to search the code base to see if I have anything that references plupload whatsoever. I do not. Yet when I run "Drush cex" it exports plupload.settings as well as settings for several other modules that are LONG GONE. When I try to "Drush cim" on the staging server the import fails complaining that these modules do not exist. I'm sure these modules are in fact referenced in the drupal database but I cannot figure out anywhere in the GUI to remove them, no option to uninstall Plupload from the uninstall page. If I do install plupload using composer it appears as a module that can be enabled under the modules page, but still no option to uninstall or remove from the Drupal database. What am I missing? Why does Drupal think I still have these modules?

Thank you!!!

0

When you removed the modules I would guess you didn't uninstall them first. The simplest approach is probably going to be to put the code back by whatever means you originally installed them, in the same location, then uninstall them via the admin panel or drush before removing the code again. That way the core code will fire that deletes the config.

It is possible that a module may break the uninstall process, in which case this is a trickier problem but best to go down the simplest route first.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.