4

Does not work:

root@deftig-web001:/var/www/1.websiteserver.net/platform# drush status --uri=dev052
 PHP executable         :  /usr/bin/php
 PHP configuration      :  /etc/php5/cli/php.ini
 PHP OS                 :  Linux
 Drush script           :  /var/www/vendor/drush/drush/drush.php
 Drush version          :  8.1.11
 Drush temp directory   :  /tmp
 Drush configuration    :
 Drush alias files      :

Works:

root@deftig-web001:/var/www/1.websiteserver.net/platform# drush status --uri=dev052 --root=/var/www/1.websiteserver.net/platform
 Drupal version                  :  7.59
 Site URI                        :  dev052
 Database driver                 :  mysql
 Database hostname               :  127.0.0.1
 Database port                   :  3306
 Database username               :  root
 Database name                   :  dev_dev052
 Database                        :  Connected
 Drupal bootstrap                :  Successful
 Drupal user                     :
 Default theme                   :  t_heftig
 Administration theme            :  t_heftig_admin
 PHP executable                  :  /usr/bin/php
 PHP configuration               :  /etc/php5/cli/php.ini
 PHP OS                          :  Linux
 Drush script                    :  /var/www/vendor/drush/drush/drush.php
 Drush version                   :  8.1.11
 Drush temp directory            :  /tmp
 Drush configuration             :
 Drush alias files               :
 Install profile                 :  heftig
 Drupal root                     :  /var/www/1.websiteserver.net/platform
 Drupal Settings File            :  sites/dev052/settings.php
 Site path                       :  sites/dev052
 File directory path             :  sites/standaard/files
 Private file directory path     :  sites/standaard/files/private
 Temporary file directory path   :  /tmp

But since I'm executing from the Drupal root, I don't see why --root is necessary. What am I doing wrong?

Drupal: 7.59 Drush: 8.1.11

2
  • 1
    Please update Drush, current release is 8.1.17, in case this is in fact a bug. Do you get the same weird behavior?
    – hansfn
    Commented Jul 31, 2018 at 7:21
  • 1
    I don't know why either. +1 on upgrading first, then run again with --debug Commented Jan 16, 2019 at 0:10

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.