2

How can I downgrade the jQuery library on Drupal 7 from 1.5.2 to 1.4.2; it looks like i've lost some functionality in Panels and Views after enabling the jQuery Update module.

3

The jQuery Update module updates Drupal's jQuery library from 1.4.4 to 1.5.2. If you don't want version 1.5.2 then you just need to uninstall the jQuery Update module and everything will go back to normal.

If you want to use jQuery Update just to update the jQuery UI library to v1.8.11 it looks like you'll have to patch the jquery_update.module file directly, as the version numbers for the base library are hardcoded into the jquery_update_jquery_replace() function using this code:

switch ($version) {
  case '1.5':
    $trueversion = '1.5.2';
    break;
  case '1.7':
    $trueversion = '1.7.1';
    break;
}
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.