0

Attempting to get CKEditor and Media to work together on a Drupal7 site. Things are mostly working great, but when I click the regular Image button (or double-click an image, or use the context menu to access image properties), I get only a gray overlay and no dialog window.

I'm using CKEditor 7.x-1.18 with the 4.10.0 FULL library locally installed (in libraries), as well as CKFinder 3.4.4 (also in libraries), all with Media 7.x-2.19 and the Media CKEditor 7.x-2.5 bridge module.

When I click the Image button, I get this error in console:

TypeError: Drupal.settings.picture is undefined[Learn More] plugin.js:152:15
init/<
http://example.com/sites/all/modules/picture/ckeditor/plugins/plugin.js:152:15
n
http://example.com/sites/all/libraries/ckeditor/ckeditor.js:10:222
CKEDITOR.event.prototype</<.fire</<
http://example.com/sites/all/libraries/ckeditor/ckeditor.js:12:42
CKEDITOR.dialog
http://example.com/sites/all/libraries/ckeditor/ckeditor.js:594:500
openDialog
http://example.com/sites/all/libraries/ckeditor/ckeditor.js:642:134
openDialog/<
http://example.com/sites/all/libraries/ckeditor/ckeditor.js:642:492
e
http://example.com/sites/all/libraries/ckeditor/ckeditor.js:258:175
y
http://example.com/sites/all/libraries/ckeditor/ckeditor.js:258:332
v
http://example.com/sites/all/libraries/ckeditor/ckeditor.js:258:412
A/e.$.onload/<
http://example.com/sites/all/libraries/ckeditor/ckeditor.js:259:327

I'm not Drupal-technical enough to understand this error entirely. But my intuition is that I don't have something configured correctly. (Installation instructions I have found are so ancient, I'm not even sure the module supports this version of CKEditor.)

0

After discovering that the Image button works fine in the default "Advanced" text format, which I did not modify, and which doesn't have the Media button added, I started investigating differences.

Turns out that if I disable the Picture module in Editor Appearance > Plugins, things work.

I just don't know what I'm giving up by disabling this. I would like images to be responsive. :-(

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.