4

I have installed the Subdomain module (v 6.1.7), and I'm configuring a subdomain for testing on localhost.

I have been tearing my hair out for days now, trying to get this module to work on my PC - and I'm still stuck on the settings/configuration stage. I have scoured the web for help in vain, and now I'm appealing for help here.

My vital stats: Win7, XAMPP, Drupal 6, Subdomain 6.17. (I gave up on 6.2 because it turned my links into www.localhost/....)

My site is localhost/ideastar.

Here are the changes I have made:

settings.php

$cookie_domain = '';

Leaving this commented out gives me an error ("The $cookie_domain variable in settings.php is not set".)

Uncommenting and putting in "localhost", ".localhost", "ideastar", ".ideastar" gives me an "Access denied" error.

It seems to accept "localhost/ideastar" or a blank ' ', although I don't know if this is the right thing to do.

host

127.0.1.1   localhost  ideastar

(and I can successfully ping ideastar)

http.conf

NameVirtualHost *:80
<VirtualHost *:80>
ServerName ideaster
ServerAlias *.ideastar
DocumentRoot C:/xampp/htdocs
</VirtualHost>

Can someone please help me get past the following errors?

Subdomain Prerequisites

To enable subdomains on your website, you must first configure the following 5 items. If something isn't working, refer to the suggested solutions and make sure you have completed each step outlined in readme.txt.

DNS server show/hide details: Not working yet
test-1.localhost: Failed to resolve
test-2.localhost: Failed to resolve
test-3.localhost: Failed to resolve

It appears your DNS server is not setup to handle wildcard subdomains (*.localhost) for localhost. Edit the DNS zone file or settings for your server to fix.

PHP caches DNS lookups, so you'll want to restart your web server after making changes to your DNS server to see the results of your changes on this page.

Web server: Unable to test Unable to test Apache settings until DNS wildcard subdomains are working Drupal's inbound URL rewriting - show/hide details: Not working yet
HTTP request to http://subdomain-test.localhost/ideally/subdomain/test resulted in an internal Drupal path of . It should have been ~subdomain-test/subdomain/test The custom_url_rewrite_inbound() function in settings.php is rewriting the internal path incorrectly. Did you patch settings.php? See readme.txt for instructions.

Drupal's outbound URL rewriting - show/hide details: Working
Drupal API: url('~subdomain-test/subdomain/test') returned 'http://subdomain-test.localhost/ideally/subdomain/test'
$cookie_domain in settings.php - show/hide details: Set
The $cookie_domain variable in settings.php is set to ''

  • $cookie_domain = ''; might actually be wrong. have you tried to set it to the actual local dev url? also, many browsers aggressively cache these configs and redirects, are you using a browser and/ or plugin to really erase the browser cache? – Alex Aug 27 at 8:27
0

I think you have to setup a virtual host in XAMPP having a different IP, like 127.0.1.2 and adjust your host file by adding 127.0.1.2 sub.ideastar.

More here (but in german.)

  • I tried the solution suggested in the link - and the errors remained the same. <1>I forgot to mention that I would like to use subdomain with Ogranic Groups; so I need to be able to use a wildcard. I just don't know how. <2> What do I put in the $cookie_domain variable in the settings.phph file? – iRex Mar 28 '12 at 10:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.